my list of noted errors

  • hei.
    first topic ive posted into german section. apologies. cant move it myself, so turns out, making other one, but this time in english section. :) no rage please!!!

    bug is when game stays open, in web browser for more than 10 minutes. one of trains, usually 3rd *by its number) becomes unselectable and without a route. its like sleeping somewhere, but cant select it also. after reloading page its all ok, but then few minutes (after general log in its 10 minutes, after reload its 3 minutes) its the same - cant select it, it has no route, it doesnt bring any money, nothing, like a ghost - cant touch, cant feel it, no use, but you can see it that it still exists in train list.

    edited: added pict Imgur: The magic of the Internet (also it has minus, negative, speed, maybe its timetraveling :D )

    The post was edited 1 time, last by RemoteTTL: added picture, where its possible to see its details ().

  • Hey,

    this sounds like a really bad bug. I wrote it down and hopefully we are able to fix it as soon as possible. I'll try to keep you updated in here.
    Thanks a lot for mentioning and for the detailed explanation. :)

  • hei.

    maybe this is not a bug, but general thing, maybe, who knows, but there isnt a passenger train any more. nor on research, nor in bonus engine section, nowhere. does this means, in future there will be no passengers who shall we transport for city leveling?

  • Hello RemoteTTL,

    the Szenario on PTR2 is the USA one. This means there are no passengers and the museum doesn't exist too. This should work fine on PTR1 and 3. :)

  • hei.

    not sure its a bug, but might be. now, when i got red kite (bonus engine), packages and offers section still offer to get one or both of them. but since PTR2 is without passenger trains, its kinda strange they have option to buy both. and even there is only one 9red kite) and i have it, it still gives me option to buy it. assume 2nd one.
    bonus engine hmm — <<< link with how i can buy it 2nd time
    bonus codes — << all offers, including getting red kite agan.

  • hei,
    Ive tried to get some videos to work. but no luck. they worked few times and then stopped. redirecting doesnt work too, in that window.
    i dont have any adblocks etc. nor they work in chrome or firefox.
    also, in mobile version there isnt a chance to log in, cause somehow, adobe says, they cant provide flash plugin for my phone (samsung). so cant watch them.
    but other realms ive tested, videos works only on cell (mobile) phone. with web browser from pc its the same - redirecting and blank screen. no videos or error message that video link has been removed or is bad.
    might be that those videos are in some server that google think its malware or suspicious, thats why they dont allow to go there. and since there isnt a option to tell - let me go there anyway, no matter of risk, videos remains dead and bonuses cant be collected.

    if you wish to collect them - get RN mobile app and then ya get them.
    still hope for some fixes, not only on PTR but also on live servers!!!!

  • Good morning RemoteTTL,

    the PTR servers do not work on mobile on purpose. You can only play the live servers on a mobile device.

    On which browser do you have those video issues? I'm sorry if you already mentioned it before in another thread but it would be nice if you could say it again.

  • hei, Karo BF.

    ok, thanks for tip about PTR and mobile.

    Using mainly Chrome. dont work. Firefox gives small video, but it stops, jumps to other video, and stops. 2 secs video, cant press on video, it reloads, but still 2 secs. and no credits no matter how long i keep pressing.

    on PTR none videos work. on live servers, only via mobile app.
    on live servers using chrome or firefox doesnt change a result. same thing over and over agan. firefox - bad link (got message in middle of screen that video might be corrupted or moved to different server) and on chrome - video jumps, doesnt load, same as on PTR.

    havent tried safari (got nix system aswell) yet and sadly cant give any feedback about Internet explorer. :)

    hope it helps somehow to solve issue all of us have on PTR servers and mostly also on live ones.

  • hei.
    agan, same old, same old:
    train without reason cancells its schedule and cant be selected and its visually has vanished. restarting the game, ptr server, doesnt help too. image: error train —


    same old video issue. there is a achievement, part of it, to watch one video to get some tutorital rewards. this cant be skipped no matter how high is level of account. and one of steps is to watch video, but since they dont work (not here, not on live servers), this cant be done. and its like 2 weekswith problem. wonder when you actually gona try fix it? should it take that long, such small issue? and many players reports this but nothing is done :D

  • Hello RemoteTLL,

    we are working on the issue regarding the train schedules and hope to fix it with the next update early next week.

    As for the videos, I just opened a thread where you can post helpful infos which we will use to find the problem.

    Best regards,

  • hei.

    competition is on, cattle to Boston. when trying to set new schedule, it gives error and nothing is done. to those trains that carries needed goods for competition, only for those if i change they schedule when competition is active and they are about to be set to other schedule, not one in competition needed goods.
    route new err 106 —

  • hei there, agan :)

    few things. as someone already sad - trains dissapear. they continue to bring profit, but visually they dont appear anywhere. i sold old engine, got new one, and it vanished after few minutes. into thin air.

    second thing - trains are at 100% of condition, dont need service, but its possible to do it.

    servicing error — <<< pict of it. when selecting all of them, cant service, but when pressing one by one, it can be done. plus third thing - one train Ive changed schedule yesterday, cant seem to go on it. remain on old one and has icon that its gona change schedule. odd.

  • hei, Stefan BF.
    yes, last ones is solved. trains are back from abyss and repairs works as earlier.
    but I still have problem with train nr5. its been like this more than a week. it remains without schedule. and new one, no matter where or how i set it, still remains in abyss, cant be selected on map, just on list. and new schedules doesnt work. this was earlier too, with same train number. since now we all have more trains, number 5 is problem, even if its model have changed (now i have panther under this nr).

    thanks for fix. thumbs up!

  • ok i see. I will have a look at your account now for a couple of minutes and come back to you.

    Update: No 5 Panther drives the schedule as expected i guess, visible at the map. Screenshot attached.

  • Yes, strange.... i had a similiar problem with my acc on PTR1 now, but this was gone after browser refresh and did not came back. We are investigating...

  • Hi RemoteTTL,

    could you clear the cache and delete your cookies? It could be, that this will solve the problem.


    uninstalled chrome and reinstalled agan. its all ok now. thanks for tips. might be cookies or something. but it works, finally. :)
    thanks to both of admins - Stefan BF and Baldur!