HTML5 Bugs 4x Speed

  • RN HTML5-Test v. 4.19.0.0/4.7.0.0

    Mac. Firefox.

    Graphik:

    -Aufbau von Fenster/Messages: immer noch “zu langsam”. (Man sieht den “Aufbau”).

    +Map-Scrolling / naviagtion mittlerweile sehr gut!

    -Stadt-Info Fenster wird sehr oft (unregelm.) nicht “populiert”. Keine Spieler zu sehen.

    -Avatar “Drop-down” nicht sichtbar.

    -Aktives/Ausgewäjhltes Kleidungs-icon wird als schwarzer Viereck dargsetellt.

    -Scrolling in Lange fenster wird oft unvollständig dargestellt. Geht nicht ganz nach unten...

    (Avatar-Kleidungen... Loks... Waren....)

    -Videos Fenster is VIEL kleiner (resolution) als das Bahn-Gelände darstellung. (!!??!)

    -Viele von den info-icons im Asso-Fenster werden falsch dargestellt.

    -In die (zb.) Ranking-Liste wird das Asso-Wappen “Matt” dargestellt. Ohne korrekte Farben.

    -Neuerdings (letzte Runde) kommt oft einen komischer “Aufbau-Loop” zurstande, wenn man das erste mal über enien Timer geht. Das zweite mal ist es weg.

    -Graphischer aufbau vom WarteZeiten in den Industrien ist ziemlich mies!

    -Beim Lok-Unbenennen steht erst einen Namen-Halter (Statt korrekter Lok-Name).

    -Im Profit-Fenster werden keine Filter (korrekt) dargestellt (Weis-auf weis??)

    -Seit letzte Runde, bleiben oft geklickte buttons “quasi-aktiv” hängen... nachdem das zugehörige fenster geschlossen wurde.

    -FP's Icon wird ziemlich oft "out-of-bound" dargestellt (rechts im Fenster).

    -Manchmal tritt ein komischer darstellungsfehler auf, bei den Bonus-Icons / Forum-Icon. (Forum-Icon verschwindet).

    -Wenn man eine Message zu jemanden schreibt, geht der Text auserhalb das eingerahmte Textfeld. (out of bounds).

  • Track Maintenance (Gleis reparatur??) wird nur als warnung (oben rechts) angezeigt, nicht aber WELCHE gleise auf die Karte die betroffen sind.

    -Ja, man kann in die Warnung lesen wo es ist.... aber; früher gab es AUF die betroffene gleise eine Warnung. - die ist nicht mehr vorhanden

  • Wenn ich EINE Lok ins Museum verschieben will, war es früher so das mann diese Lok auswählen konnte - und diese dann automatisch ausgewählt war - zur bestätigung. Jetzt ist diese Automtische auswahl weg. Wenn ich nun sage nach "museum verschieben" - sind immer ALLE Loks abgewählt. ...wenn mann IMMER nur ALLE Loks hin und her verschiebt, ist dies nicht weiter schlimm... aber wenn man mal EINE BESTIMMTE Lok auswählt, und diese verschieben will, muss mann nun ziemlich viel extra arbeit machen.

    - schlechter update (wenn es nicht ein bug ist).

  • Seit ziemlich lange, ist das Text- / communications API, oder modul, defekt! Ich meine sogar das es das ganze letzte JAHR "sehr unvorteilhaft" funktioniert hat.


    Da dieses Spiel -ziemlich elementär- auf kommunikation zwischen den Spielern baut, wäre es vieleicht SINNVOLL wenn Ihr ENDLICH diesen MIST brauchbar macht?!?!?!

    Es ist seit einige Zeit so schlimm das man kaum noch schreiben kann!! Was SOLL das?

    - Ich kann jetzt die unterste reihe im Chat nichtmal lesen! Ja; die NEUESTE Post! Wie behämmert ist das, bitte?! :D

    (**korrektur: Wenn man Neu eingelogt den chat aufmacht - fundktioniert alles normal. Wenn man aber einen post macht, gehts nimmer gut).

    -Die normalen Posts-Fenster benehmen sich auch schlimmer als sonnst... ...aber immerhin KANN man da Posten & Lesen. Nicht schlecht! :rolleyes:

    (**addendum: Der text geht jetzt weit aus dem "text-feld". (out of bounds)).

    - Entferne doch lieber diese VÖLLIG unnötige eingebaute "Copy/Paste" befehle... und benutze ein einfaches, gut funktionierendes Text-API. NUR TEXT. Nichts anderes.


    Ich wäre froh wenn Ihr es mal angehen könntet....


    X/

  • Es freut mich zu sehen das im Bahnhof wieder die Rote Buttons beim volles konto zurück sind!! :)

    - allerdings gibt es einen bug:

    Wenn man zur nächsten Spieler weiterklickt (also von derjenige der Volles konto hat), dan bleiben die "Volle Buttons" hängen... allerdings grün, aber nicht klickable.

    Kosmetika.


    ERLEDIGT!   :thumbsup:

  • Kein Bug, aber meine meinung zur neue funktion:

    -der Neue Button im Stadt-fenster "setze HeimatStadt" Screen Shot 2020-02-02 at 15.58.11.png finde ich zwar cool, aber eher blöd platziert... und eigentlich nicht wirklich sinnvoll. Es ist ja nicht so das es was bringt; täglich die Heimat-Stadt zu wechseln... :P

    Ich habe es schon mehr als 5-mal versehentlich angeklickt... also; bei mir - eher dämlichkeit, als was anderes.... aber, beim reflektieren, wie gesagt; finde ich den Button echt unnötig.

  • Es ist ja nicht so das es was bringt; täglich die Heimat-Stadt zu wechseln... :P

    Das kommt drauf an.


    Wenn du die Errungenschaften dafür vollbekommen möchtest, dann wechselst Du vor jedem Aufstieg eines Nachbardorfes mal eben Deine Heimatstadt und Du hast die 10 Stufen im nu erledigt und Deine K-Lok ist wieder ein wenig verbessert.

  • In die Indusrien-Liste, werden die Icons nur mit den Alpha-kanal (schatten) angezeigt.

    1.jpg

    Wenn man runter-scrollt, werden die später angezeigt. Also nur ein redraw fehler.

  • Übrigens: wenn das RN-Team es noch nicht bemerkt haben sollte:

    - VIELE von den "ReDraw-Bugs" treten erst beim ZWEITEN mal auf!!!! :!:

    Die unterste Zeile in den listen, oder Chat-Fenster... erscheinen also beim erstes mal völlig normal. Beim Zweites mal öffnen, oder nach posten im chat, treten fehler auf...

  • Hei Andrea Doria

    Danke für die vielen meldungen! :)

    Ich hab den Titel des Threads mal unbenannt, weil das alles allgemeine HTML5 Fehler sind und keine spezifischen 4x Speed Fehler :)


    Zu ein paar hab ich noch Fragen.

    1. Bei mir werden die Video Fenster genauso groß dargestellt wie in Flash, was meinst du denn genau mit 'zu klein'?

    2. Welche Info Icons im Gesellschafts screen?


    Die restlichen Fehler hab ich eingetragen, oder sind bereits bei uns eingetragen.

    Zum Feedback wegen dem Heimatstadt wechsel Button: Ja, das ist aktuell etwas ungünstig dass das sofort wechselt. Wir werden da noch ein Bestätigungs Pop Up einfügen, dass der wechsel nicht mehr direkt passiert.

    Die Änderung war jedoch in so fern notwendig, da wir ziemlich viele Tickets dazu bekommen haben, dass Spieler nicht finden wo sie ihre Heimatstadt wechseln können :)


    Sobald die Fragen geklärt sind, würde ich den Thread auch gerne wieder schließen, damit hier nicht wieder ein großer chaotischer Sammelbug entsteht :)


    Grüße,

    Pia

  • Hi Pia,

    1: Die Video-Fenster sind sicherlich nicht gleich!

    HTML5: HTML5.png FLASH: Flash1.png




    2: Ist schon erledigt:

    infoButtons.png


    ...die waren am anfang, genau wie (noch) viele andere kleinigkeiten, einfach versetzt... und waren unter den vorigen text gerutscht.


    ????????? =O Schließen?!?! Wieso???

    Da sind ja noch RECHT VIELE weitere punkte aufgelistet, die noch zu erledigen sind.... ?(

  • Hier nochmal errinerung an diesen -ziemlich blöden- verdeck-fehler.

    Also, wo viele fenster "abgeschnitten" werden... von GUI bereiche.


    Die treten hier und da auf. Nicht selten, wie gesagt, erst das zweite mal, wenn man dieses fenster öffnet. (der chat zb.).

    Aber - richtig blöd ist es das man nicht die Neueste Wagons kaufen kann!!!

    WagonsHidden.png
    da der knopf versteckt wird... :D

    - -

    Nicht sooo schlimm, aber ein wenig ungünstig; auch im Wettbewerb sieht man nicht wer noch mitmacht:

    Comp-Hidden.png


    Ich hoffe das Ihr diese "kleinigkeiten" schnell beheben könnt, bevor es "ernst wird"

  • Das allerschlimmste, ist aber das man (OFT) nicht die Unterste Lok auswählen kann... zb:

    Ich wollte gerade alle meine GüterLoks in die Stadt parken, zwecks WB. Also NICHT die Perso-Loks, die ich immer "nach unten" verschiebe...

    So, und - die Unterste Lok kann ich halt nicht deselektieren, sondern muss entweder diesen Fahrplan "löschen" (in die Stadt schicken), oder alle Loks EINZELN auswählen, die ich in die Stadt schicken will... ECHT blöd!


    CompPark2.png


    ?(

  • Ah okay, auf welcher Auflösung spielst du denn?

    Bei mir ist das Fenster viel größer!


    Schließen weil ich die Sachen in unsere Liste aufgenommen hab und es für uns allgemein einfach und übersichtlicher ist wenn wir für jeden Bug einen einzelnen Thread haben und nicht einen Thread wo ganz viele Bugs gemeldet werden und dann nachher welche davon unter gehen oder übersehen werden beim eintragen in unser Bug System :)


    Grüße,

    Pia

  • Ich hab einen 4K monitor... 4096 x 2304

    ...aber - das problem trat erst SPÄTER auf!! - am anfange von HTML5 war es NICHT so!!! Kann also schlecht was damit zu tun haben...

    Ja, und - wenn doch... dann müsste doch auch ALLE andere Fenster AUCH viel kleiner sein, oder nicht?!?!?! :/:P


    Na, da ist was im Code schief gelaufen. 8)


    - - -


    Ja, das mit das ganze durcheinander ist hier WIRKLICH nicht so gut ... leider. Da haste ein klaren Punkt gelandet....

    Ist es weil WIR (Postende) NIE Tags benutzen?!

    - Wie wäre es wenn Ihr eine Neue AUTOMATISCHE sortier-funktion hier im Forum einbauen würden...? Die Bug-Meldung Atomatisch einsortieren?!

    ...also, das der poster beim abschluss des posting eine frage bekommt "wohin mit die post" (mittels Tags).

    oder sowas... keine ahnung.

    (Gerade macht ja fast jeder, wenn er einen neuen "bug" findet - einen neuen Thread auf...) :S

  • Naja, in der 'neue' HTML5 version seit januar wurden ja ALLE UI Elemente im Spiel überarbeitet und angepasst um performanter zu laufen.

    Da kann es schon sein dass es in der alten Version okay war, in der neuen aber nicht :)


    Also da wir hier im PTR Forum die selbe Foren Software benutzen wie im Live Forum, ist das leider leider nicht unsere Entscheidung.

    Praktisch wäre so ein System aber schon.